Results 1 to 7 of 7

Thread: Hum on F12

  1. #1
    Join Date
    Apr 2010
    Posts
    35

    Default Hum on F12

    I have a Rythmik F12 which I bought from Ascend back in 2010. It recently started making a fairly loud humming noise. I've followed the usual troubleshooting steps. It is present both with no RCA signal input and a grounded input. It is not present when the power switch is turned off. It is present on multiple circuits in the house, and regardless of what else (or nothing) is plugged into that circuit. I have another Rythmik subwoofer in another part of the house that is still working fine so I don't believe it's anything in my house power that has changed.

    Opening up the subwoofer, I took a look at the amplifier and found that two of the 6800 uF power supply caps were bulging, with one having obvious signs of leakage. The caps were disappointingly low quality ones from JunFu, which have what seems to be a unique form factor with a 30mm diameter. I was not able to find a replacement with the same form factor, but I got 35 mm diameter replacements from Digikey manufactured by Cornell Dubilier, part #380LX682M100A052. These fit with a little encouragement, and the hum seemed to be gone for several days. Unfortunately, it has now returned and I'm not sure where to go next for troubleshooting, there weren't any other components that showed obvious signs of failure. I submitted a request form to Rythmik several days ago and haven't gotten a response yet. Any recommendations for next steps?

  2. #2
    Join Date
    May 2015
    Location
    Houston, Texas
    Posts
    1,387

    Default Re: Hum on F12

    Give Rythmik (or Ascend) a call. I'd start with Rythmik. You could also post on the Rythmik Owner's forum over on AVS... Enrico (from Rythmik) is on that forum fairly frequently.

    Also, maybe try a cheater plug as a temporary check.

    It may also be DC offset - I've seen the Emotiva CMX-2 recommended for similar hum issues and feedback has been positive.

    https://emotiva.com/collections/accessories
    * LG OLED65E6P, BenqHT2050A
    * Anthem AVM90, Rogue ST100, VTV Pascal 7 ch
    * Sierra Towers/Horizon (all ELX RAAL), S2EXv2 surrounds, HTM200SEx4 heights, Rythmik E15HPx2
    * VPI Classic 1+ (VTA & Fatboy Gimbal), PE Eagle/RR, VAS NOVA, Soundsmith Paua, Manley Chinook, Bob's Devices SUT, SugarCube 1 mini
    * Oppo 203 & 103D, EverSolo DMP-A6
    * miniDSP Flex, Audiosensibility & Blue Jeans cables, Symposium & Isoacoustics, GIK
    * For RDJ: Anthem MRX720, Sierra LX, Luna Duo v2 center, CXNv2, TBD

  3. #3
    Join Date
    Apr 2010
    Posts
    35

    Default Re: Hum on F12

    Thanks for the suggestion. I measured the DC offset on the outlet and there is only ~ 1 mV between hot and neutral, and 2-3 mV each hot to earth and neutral to earth so I doubt that is the issue. I will try calling Rythmik, I had hoped they would respond to the email form quickly but apparently not. I am guessing the solution at this point will be to replace the amplifier.

  4. #4
    Join Date
    May 2015
    Location
    Houston, Texas
    Posts
    1,387

    Default Re: Hum on F12

    Sounds like a plan. Maybe your email to Rythmik got sent to a spam/junk folder for some reason.
    * LG OLED65E6P, BenqHT2050A
    * Anthem AVM90, Rogue ST100, VTV Pascal 7 ch
    * Sierra Towers/Horizon (all ELX RAAL), S2EXv2 surrounds, HTM200SEx4 heights, Rythmik E15HPx2
    * VPI Classic 1+ (VTA & Fatboy Gimbal), PE Eagle/RR, VAS NOVA, Soundsmith Paua, Manley Chinook, Bob's Devices SUT, SugarCube 1 mini
    * Oppo 203 & 103D, EverSolo DMP-A6
    * miniDSP Flex, Audiosensibility & Blue Jeans cables, Symposium & Isoacoustics, GIK
    * For RDJ: Anthem MRX720, Sierra LX, Luna Duo v2 center, CXNv2, TBD

  5. #5
    Join Date
    Aug 2003
    Location
    USA
    Posts
    5,525

    Default Re: Hum on F12

    Quote Originally Posted by bcg27 View Post
    Thanks for the suggestion. I measured the DC offset on the outlet and there is only ~ 1 mV between hot and neutral, and 2-3 mV each hot to earth and neutral to earth so I doubt that is the issue. I will try calling Rythmik, I had hoped they would respond to the email form quickly but apparently not. I am guessing the solution at this point will be to replace the amplifier.
    I believe Brian and crew are just getting back from a vacation. They are likely way behind on emails right now. Give them a call if you can...
    .
    .
    .
    Good Sound To You!

    David Fabrikant
    www.ascendacoustics.com

  6. #6
    Join Date
    Apr 2010
    Posts
    35

    Default Re: Hum on F12

    An update to this problem:

    I got in touch with Brian at Rythmik and he suggested replacing two additional capacitors on the amplifier. After swapping those, the humming has been eliminated. Great support from Rythmik!

  7. #7
    Join Date
    May 2015
    Location
    Houston, Texas
    Posts
    1,387

    Default Re: Hum on F12

    thanks for the update. Glad it's all fixed!
    * LG OLED65E6P, BenqHT2050A
    * Anthem AVM90, Rogue ST100, VTV Pascal 7 ch
    * Sierra Towers/Horizon (all ELX RAAL), S2EXv2 surrounds, HTM200SEx4 heights, Rythmik E15HPx2
    * VPI Classic 1+ (VTA & Fatboy Gimbal), PE Eagle/RR, VAS NOVA, Soundsmith Paua, Manley Chinook, Bob's Devices SUT, SugarCube 1 mini
    * Oppo 203 & 103D, EverSolo DMP-A6
    * miniDSP Flex, Audiosensibility & Blue Jeans cables, Symposium & Isoacoustics, GIK
    * For RDJ: Anthem MRX720, Sierra LX, Luna Duo v2 center, CXNv2, TBD

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •