Page 1 of 3 123 LastLast
Results 1 to 10 of 24

Thread: Hello from Ohio

  1. #1
    Join Date
    Oct 2022
    Location
    Franklin Furnace, Oh
    Posts
    21

    Default Hello from Ohio

    Just purchased some used 340SE's. Liking in very much. Hearing things I didn't hear with my other tower speakers. Getting some breakup in the highs with very much volume. What amplifier does everyone recommend for these speakers? Thanks for having me!!

  2. #2
    Join Date
    Aug 2003
    Location
    USA
    Posts
    5,222

    Default Re: Hello from Ohio

    Quote Originally Posted by Hiwayjunkie View Post
    Just purchased some used 340SE's. Liking in very much. Hearing things I didn't hear with my other tower speakers. Getting some breakup in the highs with very much volume. What amplifier does everyone recommend for these speakers? Thanks for having me!!
    That sounds like amplifier clipping. What amplifier are you currently using and how far back are you sitting from the speakers?
    .
    .
    .
    Good Sound To You!

    David Fabrikant
    www.ascendacoustics.com

  3. #3
    Join Date
    Oct 2022
    Location
    Franklin Furnace, Oh
    Posts
    21

    Default Re: Hello from Ohio

    Using a Kenwood KA-7002. Sitting about 10 ft away from speakers. Thanks

  4. #4
    Join Date
    Aug 2003
    Location
    Manhattan Beach, California
    Posts
    6,927

    Default Re: Hello from Ohio

    Quote Originally Posted by Hiwayjunkie View Post
    Using a Kenwood KA-7002. Sitting about 10 ft away from speakers. Thanks
    Wow...that is vintage! How loud do you listen?

    Do you have a budget for something new?
    -curtis

  5. #5
    Join Date
    Oct 2022
    Location
    Franklin Furnace, Oh
    Posts
    21

    Default Re: Hello from Ohio

    I also have a NAD C-350, and a Marantz 2238B. I have been thinking on something new. Would love some recomendations

  6. #6
    Join Date
    May 2015
    Location
    Houston, Texas
    Posts
    1,107

    Default Re: Hello from Ohio

    Budget?
    * LG OLED65E6P, BenqHT2050A
    * Anthem AVM70, Rogue RP5 & ST100, VTV Pascal 7 ch
    * Sierra Towers/Horizon (all RAAL), Sierra 2 surrounds, HTM200SEx4 heights, Rythmik E15HPx2
    * VPI Classic 1+ (VTA Tower, Fatboy Gimbal), PE Eagle/RR, VAS NOVA, Soundsmith Paua, Manley Chinook, Bob's Devices SUT, Sugar Cube 1 mini
    * Oppo 203 & 103D, CA CXNv2
    * miniDSP Flex, Audiosensibility & Blue Jeans cables, Symposium & Isoacoustics, GIK
    * For RDJ: Anthem MRX720, Sierra LX, Luna Duo v2 center, and rest TBD

  7. #7
    Join Date
    Aug 2003
    Location
    Manhattan Beach, California
    Posts
    6,927

    Default Re: Hello from Ohio

    Try the NAD.

    Same question: Budget?
    -curtis

  8. #8
    Join Date
    Oct 2022
    Location
    Franklin Furnace, Oh
    Posts
    21

    Default Re: Hello from Ohio

    Around a thousand

  9. #9
    Join Date
    May 2015
    Location
    Houston, Texas
    Posts
    1,107

    Default Re: Hello from Ohio

    If none of your existing options work for you, maybe look on USAudiomart or Audigon for a previous generation Anthem AVR (eg x20, x10, x00) or an integrated from Rogue Audio (unless you aren't interested in tube equipment),
    * LG OLED65E6P, BenqHT2050A
    * Anthem AVM70, Rogue RP5 & ST100, VTV Pascal 7 ch
    * Sierra Towers/Horizon (all RAAL), Sierra 2 surrounds, HTM200SEx4 heights, Rythmik E15HPx2
    * VPI Classic 1+ (VTA Tower, Fatboy Gimbal), PE Eagle/RR, VAS NOVA, Soundsmith Paua, Manley Chinook, Bob's Devices SUT, Sugar Cube 1 mini
    * Oppo 203 & 103D, CA CXNv2
    * miniDSP Flex, Audiosensibility & Blue Jeans cables, Symposium & Isoacoustics, GIK
    * For RDJ: Anthem MRX720, Sierra LX, Luna Duo v2 center, and rest TBD

  10. #10
    Join Date
    Aug 2003
    Location
    USA
    Posts
    5,222

    Default Re: Hello from Ohio

    Quote Originally Posted by Hiwayjunkie View Post
    Using a Kenwood KA-7002. Sitting about 10 ft away from speakers. Thanks
    It is likely that your power supply filter capacitors are drying up and as such, ripple current is not being properly handled. I'd say it is time to replace the Kenwood, or have it refurbished.
    .
    .
    .
    Good Sound To You!

    David Fabrikant
    www.ascendacoustics.com

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •