Results 1 to 7 of 7

Thread: Problem with WASAPI exclusive mode and Qobuz

  1. #1
    Join Date
    Mar 2022
    Posts
    132

    Default Problem with WASAPI exclusive mode and Qobuz

    Hi,

    I'm hoping somebody here might have some suggestions about how to get WASAPI exclusive mode to work well with Qobuz. From what I've read, the exclusive mode is the simplest and cleanest way to get bit-perfect audio, and that's what I'd prefer.

    Unfortunately, on my Windows laptop, the audio gets distorted and unplayable using it. The regular WASAPI mode seems to work fine, but that's doing a couple of conversions to the audio stream which I'd like to avoid.

    Thanks in advance!

  2. #2
    Join Date
    Aug 2003
    Location
    Manhattan Beach, California
    Posts
    6,894

    Default Re: Problem with WASAPI exclusive mode and Qobuz

    first...my two cents...

    Windows audio is a pain! I ditched it a long time ago. You are better off getting an inexpensive streamer that supports Qobuz.

    That said, have you enabled exclusive mode in the device driver?
    -curtis

  3. #3
    Join Date
    Mar 2022
    Posts
    132

    Default Re: Problem with WASAPI exclusive mode and Qobuz

    Well, it's too late for that - just bought this laptop to use with qobuz, so my wife can have her I-pad back. I agree it's a pain, having to work around Windows monkeying with the audio, but I thought WASAPI exclusive was an easy and good way to do that.

    How would I do that? I just looked at the speakers properties page, and it shows the box to allow exclusive control is checked. Is there something else to try?
    Last edited by James; 08-24-2022 at 11:33 AM.

  4. #4
    Join Date
    Aug 2003
    Location
    Manhattan Beach, California
    Posts
    6,894

    Default Re: Problem with WASAPI exclusive mode and Qobuz

    I don't have access to a Windows machine to walk through it. I gave my Windows PC to my Dad when I stopped using Roon with it.

    Have you tried Google? Maybe it is set in the Qobuz app?
    -curtis

  5. #5
    Join Date
    Feb 2016
    Location
    Loveland, Colorado
    Posts
    53

    Default Re: Problem with WASAPI exclusive mode and Qobuz

    Looks like Curtis is correct. According to this Qobuz help page, WASAPI (Exclusive mode) is set in the app. (Note, I'm not a Qobuz user, but I do use Windows exclusive mode in JRiver, which is also set within the JRiver app.) Hope this helps.

    https://help.qobuz.com/hc/en-us/arti...-Hi-Res-on-PC-

    *The playback modes are set through your Qobuz app by clicking on the audio devices button at the bottom right.
    We recommend that you choose:

    • WASAPI (Exclusive mode) : this mode is available for Windows Vista and Windows 7. It is to be avoided if you do not have a powerful processor and if you prefer the ASIO.
    • ASIO : Audio Stream Input/Output allows up to 24-bit at 96 kHz


  6. #6
    Join Date
    Mar 2022
    Posts
    132

    Default Re: Problem with WASAPI exclusive mode and Qobuz

    Yes, of course it's set there, and I had set it there. Before I bought anything, I did a fair amount of research to make sure this would work - I'm not an impulse buyer.

    The problem was solved temporarily by increasing the buffer size before playback in the Qobuz settings. But then, of course TuneBlade wouldn't work, because the exclusive mode didn't let it. So I had to use the regular WASAPI mode anyway.

    Then followed a very frustrating problem which took me a day to fix. It turned out that Microsoft had locked my account for some reason, and I had to unlock it. Then I was able to enable sharing with nearby devices, and now I have beautiful Qobuz streaming music playing on our system, after passing through the laptop, TuneBlade and the Audioengine B-Fi.

    It's a complex way to set up an essentially simple thing, which is much simpler on I-pads, but this way is much less expensive. So as long as it keeps working, I'll be happy.

  7. #7
    Join Date
    Aug 2003
    Location
    Manhattan Beach, California
    Posts
    6,894

    Default Re: Problem with WASAPI exclusive mode and Qobuz

    Quote Originally Posted by James View Post
    The problem was solved temporarily by increasing the buffer size before playback in the Qobuz settings. But then, of course TuneBlade wouldn't work, because the exclusive mode didn't let it. So I had to use the regular WASAPI mode anyway.
    TuneBlade...so you are using AirPlay?

    You do realize AirPlay resamples everything to 24bit/48khz regardless of what it's fed. I hope that is not how you are feeding your Ascends.
    Last edited by curtis; 08-25-2022 at 04:51 PM.
    -curtis

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •