PDA

View Full Version : How I got these amps...



curtis
01-17-2006, 03:14 PM
So I thought I would post this story because it is very weird, intrigueing, and happenned to me.

About six months ago I was contacted by someone on the AVS forum about listening to my Ascend setup. The guy was going to be in town on business. You all know that I am open to that. We sent PM's/email back and forth, and set a timeframe.

During our PM discussion he mentioned that he wanted to try the Ascends with NuForce amps. These amps at the time(and now) were getting a lot of high praise(I know some of you do not believe amps make a difference....so lets leave that for another thread :) ). I half jokingly told him to send the amps ahead of time for me to check out and he can take them home after the listening....the amps are small, light, and easy to travel with. To my surprise...he agreed! So about a week later...a pair of NuForce Ref 8b amps show up at my house. I hooked them up and was very happy.

I used the amps for about week....and thrilled with the sound and ready for the guy's visit. Well something happenned and he could not make it to California. We emailed and chatted on the phone to reschedule for the following week.....he said he would call when he was certain. Apparently he was stuck somewhere in the midwest helping with a commercial....he lives in Chicago.

Another week goes by...I think this is now the third week that I have had the amps....and one of them just quits working.....oh crap! So I call him and tell him what happenned and ask what he wanted me to do.....I could easily send it in for repair for him. He told me he would think about it and call me back....this was back in August.

I have not heard from him since! Numerous emails and phone calls(I leave messages) and nothing in return.

So in November I call NuForce to tell them my story and ask about repair...also wonder if they can call the owner since they have record of it. I get a call back saying they had the same type of issue with the guy when he got the amps on trial.....when his 30 days were up, they tried to contact him to let him know they were going to charge his card...he never called back and they charged his card, and this time they left another message for me. So as far as they were concerned, the amps were paid for and under warranty. I asked for an RMA number and they gave me one.

I held on to the amps a couple more months and called the guy a couple more times(left more messages) and still got nothing. So last week, I sent the amps in for repair and updating. The amps have another 2.5 years warranty.

I got the amps back yesterday and hooked them up.....and they just sound sweet(if it psycholgical...I don't care at this point)! A pair of these monoblocks retail for $1800...not something I think I would buy on my own.

I am not complaining or anything, but is that weird story or what? Wonder what are the chances of that happening with a house in Manhattan Beach. :)

The website for the amps is:
www.nuforce.com and there is a dedicated NuForce section on Audio Circle.

bikeman
01-17-2006, 03:37 PM
I am not complaining or anything, but is that weird story or what?
Weird it is but I'm glad it happened to one of the best posters on the audio groups. ;) I'm sure you'll let us know if you ever hear from this guy again.

David

Dave G
01-17-2006, 05:16 PM
Great story! This may be a dumb question, but how do the NuForce monos compare to your existing (previous) amps? I've been spending way too much time lately over on the Audio Circles forum and am real curious about both the NuForce and Channel Islands amps.

Dave

Lou-the-dog
01-17-2006, 05:33 PM
OHHHH! So YOU ended up with MY AMPS!!! I went thru a bout of amnesia :confused: and I had given up hope that I would ever remember where I sent them. Whew! You just made my day Curtis. My address is in my profile. Oh Yeah, thanks for gettin' em fixed for me too. :D

Randy

bikeman
01-17-2006, 08:00 PM
Oh Yeah, thanks for gettin' em fixed for me too. :D
Randy
You crack me up. :D

David

BradJudy
01-17-2006, 09:14 PM
That's crazy Curtis. It's the type of thing that would sound like a scam if you hadn't gotten the ok from NuForce.

I heard them once at the RMAF.

BTW: Feel free to send me your old amp. :)

curtis
01-17-2006, 11:39 PM
Yeah guys....crazy, funny, and weird.

I just check on AVS and the guy's last activity there was August 5, 2005......he first contacted me July 23, 2005.

It has also been suggested that it may have been some kind of ploy to get me to post about the amps. It is not every day that someone thinking about buying Ascends is also going to spend $1800 for a pair of monoblocks to drive them.

And to let some wind out of my sails, I took the NuForce amps and my ATI 1502(bought used for $300) to compare to my friend's Tapco pro-amp that he got for $220.

What difference did we hear? We played Fiona Apple's "Oh Well" off of her latest CD. At first we did not level match and thought the NuForce had less sibilance....but then we leveled them and guess what.....the ATI and the Tapco did not have any readily apparent differences...the NuForce seemed to have a bit tighter bass. That was the only difference we could hear in about an hour of listening to the same song and switching amps.

The amps are now back in my system...I like them. :)

davef
01-18-2006, 02:27 AM
Ha.. I told you not to post this ;)

You are now going to get email after email from people making claim to those amps...

still.... couldn't have happened to a nicer and more deserving guy (unless it was me :rolleyes: )

try not to blow them up this time :p

picasso
01-18-2006, 06:32 AM
I had been searching for a Bryston 5 channel amp or a Lexicon amp (actually made by Bryston).

On Ebay one day and notice a new Lexicon NT 512 (retails at $3495) with no bids and closing within 4 hours. I picked a number to bid (it had a reserve) and lo and behold, I happened on their minimum ($1500).

No one else bids and I win the auction. Nothing like this happens to me so I'm skeptical of my good-fortune. Before sending payment via credit card, I checked out the business website of the seller. They custom install high end systems throughout the country and their latest project was an install on a $40 million yatch. Apparently, they ordered an extra of everything needed for this install in case they had a problem with one and sold the extras not needed afterwards. They must have made a bundle on this project.

Still skeptical, I contacted Bryston Corp out of Canada with the serial number and they confirm it's a new amp with full warrantee and congratulate me on my good deal.

Four years later, I still have the amp, that if desired, could sell for more than paid originally. Sound is too sweet to sell though. I'll keep it forever.

Eddie Horton
01-18-2006, 08:12 AM
I really like to hear stories like this, especially when they happen to deserving people. The only problem is that they never happen to me. Hmm, what is that telling me?

curtis
01-18-2006, 12:45 PM
Ha.. I told you not to post this ;)

You are now going to get email after email from people making claim to those amps...

still.... couldn't have happened to a nicer and more deserving guy (unless it was me :rolleyes: )

try not to blow them up this time :p
LOL!! Too late...I got your email this morning...you stay up way too late. When Randy posted about his amnesia....I knew I might be in trouble.

Eventhough my buddy and I didn't hear a whole lot of difference in amps at his place....for some reason, I really like the sound at my place. If it is psychological, I can accept that. In any case, my system has some added "bling".

These amps are so small and light, it is pretty funny. I attach my fat speaker cables, and the amps move. I let my buddy borrow my 2-channel ATI, but when I get a chance, I will snap some pictures of the amps to give you guys a visual.

Anyways, if the amps' owner wants his demo...I am ready! :)

curtis
01-18-2006, 02:23 PM
oh...I wanted to add that the Tapco amp was sent up for 500 watts/channel, the ATI is 150 watts/channel, and the NuForce Ref 8b is 100 watts/channel.